
AY 105 Lab Experiment #3: Optical aberrations

Purpose

In this lab you will study the imaging performance of real lenses, that is, those
used in the non-ideal case of real world optics. You and your lab partners will simulate
optical raytracing using a computer program on a PC in the lab, and compare the
calculated results to the performance of actual optical elements on the lab benches.
In the first day’s lab you will study lenses (an achromatic doublet and a plano convex
lens) while learning the basics of the ’Code V’ program. In the second day’s lab you
will study far off-axis images from a concave mirror.

Pre-lab Work

• Skim the lab but don’t worry too much about understanding the software in-
structions as these technical parts are better appreciated when you see them in
operation.

• Skim the additional material on the CodeV ray tracing software so that you have
an idea of what optical design is all about. This chapter from the software User’s
Guide goes through the case of a digital camera lens, which is not our situation,
but it’s helpful nonetheless.

• Review basic concepts in optical abberation (i.e. deviation from the simple par-
axial optical theory we have been using thus far) such as: spherical aberra-
tion, astigmatism, coma, field curvature, distortion, chromatic aberration, lateral
color.

Background

Diffraction, refraction, reflection, and scattering are all important processes that
affect photons from the time when they are incident on the first optic and as they pro-
pogate through the system to the detector. Ray tracing is commonly used in optical
design to simulate the behavior of light waves as they travel through sometimes very so-
phisticated instruments. In general, raytracing programs take as input the parameters
of lenses and other optical elements, then produce drawings such as “spot diagrams”
to visualize what your perfect incident wave looks like at the end of the optical train,
and analyze the image quality of an optical system.

Code V (pronounced “code-five”) is an industry-standard optical design software
package written by Optical Research Associates of Pasadena. Although it is a quite
powerful system, the command interface can be somewhat perplexing. A menu-based
mode (“screen mode”) is operated through the “Lens Data Manager” window and is
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designed to ease data entry. Advanced users may wish to learn the command line
language and type into the box at the bottom of the Command Window.

Equipment List

PC w/ Code V (note that a license update is needed each year)
QTH Lamp #63200
Power Supply #6394
Opal Glass Diffuser
Condensing Lens (50mm diameter, 75mm focal length)
25 micron (one group) or 30 micron (other group) Pinhole
75 mm Diameter Photographic Telephoto Lens
Microscope w/ x,y,z Adjustments
Achromatic Doublet #31402
Plano-Convex Lens #32974 (50 mm Diameter, 150 mm FL)
Reference Flat
3-point Spherometer (one group) or single-point (other group) Spherometer
Center Thickness Gauge (share between groups)
Rotational Stage
80 mm EFL f/2.8 triplet Lens (optional)

Adjustable Mirror Mount
Mirror 1 m RoC, 500 mm FL
HeNe Laser
Laser mount and positioner

Experiment

Part A: Lenses

Part A Configuration - Optical Bench

You will either find the optical table already configured with a collimated light
source illuminating your test lenses, and a microscope to examine the resulting images
(highly recommended for the motivated TA), or you will have to set this up using your
now-honed skills in optical alignment. Remember during to check the properties (e.g.
location, size, brightness) of the light ray bundle as it proceeds through your optical
train to make sure the behavior is as you expect, notably before and after each optical
element.

The collimated light is provided by the QTH lamp, opal glass diffuser, and a
condensing lens to concentrate the diffuse light onto a pinhole. One group’s pinhole is
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25 µm diameter, while the other group’s is 30 µm diameter. Light emerging from the
pinhole is diverging, but is then collimated by a photographic telephoto lens, producing
a parallel beam roughly 75 mm in diameter in which you will locate your test lenses.
The collimated beam travels the length of the optical rail, at the other end of which
is located a microscope that can make fine adjustments in each of the “x, y, and z”
directions. Make sure there are lenses in the microscope (10x will do). The test lens
holder will be mounted on top of the rotational stage on the rail carrier, between the
telephoto lens and the microscope. You will test both an achromatic doublet lens and
a plano-convex lens.

Sketch the setup thus far in your lab notebook, recording the diameter of your
pinhole, the EFL (effective focal length) of your telephoto lens, and the magnification of
your microscope. As always, label the relevant dimensions. What angle in arcseconds
is subtended by the pinhole diameter in the focal plane of the telephoto lens? There
are a number of different telephoto lenses around; which properties of these lenses will
produce the smallest pinhole image and is smaller always better?

Before taking actual measurements with the lenses you will first construct a model
for their behavior.

Part A Configuration - PC Model

Now move to the PC computer. Start Code V by double-clicking its icon on the
Windows Desktop. Eventually the Code V session will start and several windows will
appear. In Code V, optical elements are entered one-by-one in the sequence of surfaces
they present to light rays entering the system. These surfaces are denoted as “S0”
(object plane), “S1” (first optical surface), “S2” (second optical surface), etc.

The precise commands needed to enter the lenses used in the lab are given below.
Try to pay attention to the reasoning behind the commands, rather than just reading
and following directions. You may wish to switch among the partners in navigating
the Code V command execution, or have specialists.

Part A Measurements - PC Model for Achromatic Doublet

For the achromatic doublet lens there are two surfaces for the positive (crown
glass) element and two for the negative (flint glass) element.

First, name your lens file by going to the File menu and choosing “Save As.”
The software will add “.len” to the end of the filename you specify and save the lens
definition in C:\CVUSER. You can begin by entering the parameters for the achromatic
doublet lens. Enter a title for your lens by clicking on the Lens menu, choosing “System
Data,” then System Settings and the option to set a title. Something like “Ay 105
achromatic doublet” would be a good choice.
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Now go to “Lens → System Data” and the wavelength section to indicate that
you want to enter three wavelengths. Specify a red, green, and blue wavelength in
nanometers (e.g. 750, 550, 400). Other fields in this dialog box can stay at their
default values. You will have to click “commit” for your values to be stored.

Click on the input window at the center of the screen, where you will already see
the object and image surfaces entered at infinity. Right click on the block that says
“Image” and select insert. Insert two surfaces. The input window will then include
lines for Stop and 2-3. Stop represents the aperture stop. For our lens, the stop is
surface 1, so this is OK. You will enter the surface properties for the lens surfaces on
these lines.

Specify the lens as follows.

Surface Name Y Radius Thickness Glass Refract Mode X/Y Semi-Aperture

Stop 203.94 11.94 NBK7_SCHOTT REFR 31.75
2 −156.41 8.86 SF2_SCHOTT REFR 31.75
3 −569.57 343.67 REFR 31.75

The X and Y semi-aperture may appear gray in the screen, and not allow you to
enter values. If this is the case, right-click on the surface number column, and choose
“Surface Properties.” Enter the Y semi-aperture, and the X semi-aperture should
adjust accordingly since you have specified a circularly symmetric lense. The “Refract
Mode” column specifies whether the surface is reflective or refractive. NBK7 and SF2
are types of glass, and Schott is the manufacturer. Ignore any error messages about
the glass no longer being available.

With the optical elements now entered, analysis can be performed, including
generating plots of all the surfaces and tracing a set of standard rays through them.
Specify that we want to trace f/5.6 rays through the system by going to the “Lens →

System Data → Pupil.” Specifying a F/N value of 5.6. Save your lens definition.

You can see a lot of data about the lens you have entered by going to “Display
→ List lens data → All lens data.” You can also display a picture and a 3D model of
your lens from the View menu or the various buttons at the top of the screen.

Our goal here is to evaluate chromatic aberration of this doublet. We’ll do that
by producing a spot diagram in front of, at, and behind the nominal focus. Go to
“Lens → System Data → Through focus” to define the focus positions we want to look
at. We’ll look at: three positions, starting position -1.5, and increment 1.5 (and so at
the nominal focus, plus 1.5 mm, in front, and minus 1.5 mm, behind).

Having done that, go to “Analysis → Geometrical → Spot diagram.” The three
spot diagrams will appear in their own window. (You may have to wait a bit).
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You should find a way to save the spot diagram. Making sure the spot diagram
window is in front, “alt-PrintScreen” will capture the screen for you to save and using
sftp to move files to another computer, you print elsewhere. You can also try “File
→ Print” to print to the lab B&W printer (HP Laserjet 1100). But the colors are
definitely helpful for your analysis.

Which focus setting is best for red? for green? for blue? What does this tell you
about the achromatic doublet?

Now, let’s make a field map showing the RMS spot size as a function of x and y
field angle. That is, we’ll see how the image of a point grows as we move off-axis. Go to
“Analysis → Diagnostics → Field Map.” On the first panel page, open the drop-down
menu for type of display and choose “RMS Spot Diameter.” On the panel including
“Field Description,” we want a range of field angles, so switch the pull-down menu to
“Field Angle” and specify the X and Y field angles as having a minimum of -10 degrees
and a maximum of 10 degrees. Then hit okay and wait until the diagram appears.
Screen capture or print it, if you’d like, and note your observations.

You can perform other analyses by exploring the CodeV menus. Remember to
hit the “okay” or “commit” button after setting the parameters, and look for plots in
the plot window and textual results in the command window.

If you want to add off-axis rays to spot diagrams and raytraces, you can add
them from the “Lens → System Data → Fields/Vignetting” menu by specifying more
X angles. Is the focal surface of the achromat a plane?

Make sure to save your Code V achromatic doublet lens design to a file on the
disk.

Part A Measurements - PC Model for Plano Convex Lens

Next you will apply the Code V commands you’ve experimented with in order
to perform a raytrace analysis of the 50 mm diameter 150 mm EFL plano-convex lens
you used as the camera in front of the photodiode during Lab #1. This lens is in the
envelope labeled #32974; unpack it and lay it flat side down onto the tissue packing
paper on the optical table or computer work area. The lens is made of Schott glass
NBK7, but in order to input its design into Code V you will need to measure its radii
of curvature and center thickness.

Your “Optics” drawer contains a device called a “spherometer” to measure the
radius of a spherical surface. Remove this device from its package and describe its
operation in your lab notebook (you might also find it interesting to examine the other
group’s spherometer—which is different—after they are finished with it). You will
also need a small reference flat with which you can determine the zero-point of the
spherometer. Three things you should keep in mind when using the spherometer are:
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(1) the lens surface should be free from dust so you should ask if cleaning optics has not
been covered in lab before; (2) the test point(s) of the spherometer are hardened steel,
and can scratch the lens if dragged across it—instead you should lower the spherometer
straight down onto the surface of the lens and lift it straight off before moving it, rather
than dragging it across the surface; and (3) the dial is calibrated in units of diopters,
which are the reciprocal of the focal length in meters a thin lens would have if one
surface had the measured radius, the other surface was flat, and the index of refraction
of the material was 1.523 —so you must use the thin lens maker’s formula (covered in
lecture) to convert your diopter measurement into an actual radius. If your group has
the “3-point” spherometer, one additional thing you must keep in mind for accurate
measurements is the angle the spherometer makes with the surface normal—use a
slight rocking motion while watching the dial, and record the extreme reading when
the spherometer is normal to the lens surface.

Along with the diopter measurement record an uncertainty estimate in your lab
notebook (in diopters), and when converting from diopters to radius in millimeters also
determine the ± error bounds on the measured radius.

Now flip the lens over on the tissue and measure the other surface with the
spherometer. Is your measurement consistent with this surface being flat and the lens
plano-convex? What is the smallest radius the “flat” surface could have and still be
consistent with your measurement uncertainty?

Next you must measure center thickness of the lens, and there is a third gauge
designed for this purpose. Make sure the central regions of the two lens surfaces are
dust-free, and carefully separate the gauge calipers, move the calipers to the center of
the lens, and carefully let them close. For best results the gauge calipers must be at
the center of the lens and normal to each surface; try to keep any dragging motion to
a minimum, but some motion will be necessary to locate the lens center. As you might
imagine from the usefulness of the “thin” lens equation, the lens design is not likely to
depend critically on the center thickness, so it is not necessary to spend a long time
trying to measure the center thickness with the utmost accuracy. Record your center
thickness measurement and uncertainty estimate in your lab notebook.

When you’re ready to enter the singlet lens data, reset Code V with “File →

New” and specify wavelengths, the entrance pupil, and surfaces as you did before.
Enter the lens parameters, using 140 mm as the distance from the last lens vertex to
the next surface. In other words, you can set the thickness of the surface 2 to 140 mm,
and its radius of curvature to what you calculated for the lens. Set the thickness of
the stop to whatever you measured for the lens.

Conduct an analysis similar to the one you did for the achromat. How do the
predicted best focal distances for the red, green, and blue rays compare? How is this
different from the achromat?
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The “Analysis → Diffraction → Wavefront Analysis” option may help you evalu-
ate focus by finding the best focus. Note that it finds the best focus for each wavelength
being studied, and weights them according to the weights in the “Lens → System Data
→ Wavelengths” menu. It expresses them relative to the “reference wavelength” spec-
ified there. To get the focus shift from the reference for a single wavelength, set the
weights for the other wavelengths to zero.

In Lab #1 you measured the focus translation necessary to maximize the signal
detected by the photodiode for each interference filter wavelength. Compare the sep-
aration you measured in Lab #1 between the 400 nm and 700 nm foci to the results
from Code V. At what intermediate focus position does Code V predict the smallest
blur circle (for white light)? Adjust the lens design database so that the final image
plane roughly coincides with this intermediate position and perform a spot diagram
analysis. What is the image diameter at this best focus?

Make sure to save the Code V plano-convex lens design to a file on the disk.

Part A Measurements - Optical Bench / Plano Convex Lens

Now take the plano-convex lens and mount it in the lens holder, then insert the
lens holder into the post holder on the rotational stage. Adjust the vertical height to
align the lens center with the center of the telephoto lens (to within an accuracy of a few
millimeters—remember that the light emerging from the telephoto is ∼ 75 mm diameter
and parallel, so that vertical (z) and horizontal (y) centering are not especially critical).
You can achieve an approximate y-centering by rotating the stage until the post-holder
knob is aligned with the direction of the rail; this rotation will then correspond to
“zero” degrees off-axis.

Turn on the QTH lamp, and move the lens carrier along the rail until the image
of the pinhole is seen just in front of the microscope objective (you will need to turn
out the room lights to be able to see the pinhole image at the lens focus, perhaps
also removing the opal diffuser for better illumination). Move the microscope stage
to center the pinhole image formed by the lens in the objective, and then focus the
microscope while looking through the eyepiece until the image size is smallest.

Replace the opal glass diffuser and adjust the QTH source and condensing lens –
without moving the pinhole or telephoto lens collimator – to maximize the illumination
of the pinhole. Recheck the alignment of the microscope, which should be very close
to where it was previously. Describe in your lab notebook what you see when you sweep

the microscope focus in and out from the best focus for the pinhole, by moving the stage

in the x direction. Compare your observations to the translation data from Lab #1 and

to the Code V results qualitatively, and as quantitatively as you can.

Part A Measurements - Optical Bench / Achromatic Doublet
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Replace the plano-convex lens on the bench with the doublet lens (#31402) and
repeat the comparison between theory and observation as outlined in the previous two
paragraphs. Quantify wherever possible how much better is the achromat performance
as compared to the plano-convex singlet lens.

Part A Extra Time

If there is extra time you can explore off-axis effects. Rotate the lens about
the vertical axis of the rotational stage by a few degrees and notice any changes to the
image as viewed through the microscope (refocus the microscope as necessary). Choose
a particular rotation angle (or two) and specify the field angle(s) in Code V to produce
a series of spot diagrams over the focus range. Qualitatively compare the appearance
of the actual image to the spot diagrams. Estimate from the Code V results the size
of the image at your off-axis angle, and convert this linear spot size to arcseconds in
the focal plane.

Additionally, you may wish to examine the images (off-axis especially) produced
by the 80mm EFL f/2.8 triplet lens, which is an example of the Cooke triplet design.
In Code V there is a sample lens file for a Cooke triplet, but this does not describe the
identical lens used on the bench.

Finally, if using Code V went smoothly and time permits, you may wish to quan-
tify your microscope observations of the spot diagram using the micrometer eyepiece.
The instructor or T.A. can give you a “Ronchi Ruling” to calibrate the eyepiece scale
divisions when used with the microscope.

Part A Analysis. Convert any “raw” measurements made during the lab to
more meaningful units. Specifically, for both the plano-convex lens and the achromatic
doublet, use the on-axis spot size you derived to estimate the resolving power of the
lens in “line pairs per millimeter” units. Lastly, take the lens data for the achromat
given in the Cookbook and calculate (with pencil, paper, and a hand calculator—not
with Code V!) the power of the individual crown and flint elements under the thin lens
approximation. If the Abbe number νd of the NBK7 crown glass is 64.17 and that for
the SF2 flint glass is 33.85, are your approximate element powers consistent with the
combination being achromatic?

Part B: Mirrors

Part B Configuration and Measurements - Optical Bench

Starting from the optical table setup used in Part A, remove the lens holder and
microscope from the path of the collimated light. Bolt a post holder to the optical table
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breadboard in the beam beyond the microscope’s location, and insert the support post
of the adjustable mirror mount. Reposition the microscope alongside the rail (but now
pointed in a direction towards the mirror). Pay attention to set up the microscope
near the mirror focus. The mirror is spherical and has a 1000 mm radius of curvature,
for a focal length of 500 mm. So as to see images from the mirror with the microscope,
you will be using the mirror off-axis.

The image of the pinhole formed by the mirror is very difficult to find. You will
want the microscope located as close to the rail as possible without blocking the parallel
light between the telephoto lens and the mirror, so that the off-axis angle will be as
small as possible. Once the mirror and microscope are setup it will help tremendously
if you replace the QTH light source with the HeNe laser. The laser is used only for the
alignment, as described below.

Without changing the position of the post collars, remove the QTH light source
and condensing lens (but leave the pinhole where it is), and insert the post of the laser
mount into the post holder used for the light source. By adjusting the laser alone,
you should be able to get some laser light to pass through the pinhole. This will then
produce a more visible beam (no more than a centimeter in diameter, however) which
you can follow as it reflects off the mirror. DO NOT LOOK DIRECTLY INTO THE

BEAM; even though it has been attenuated by the pinhole and expanded in diameter
by the collimated lens, the laser light is still intense and would be focused by your
eye lens back to a point on your retina, so avoid eye contact with it and as always
remember to be conscious of where reflections send the laser light. You may now adjust
the spherical mirror so that the reflected beam is directed towards the microscope (BUT

DO NOT LOOK THROUGH THE MICROSCOPE AT THE LASER LIGHT ); use a
piece of paper to establish approximate alignment.

Once you have approximate alignment using the laser, measure the off-axis angle
between the microscope angle and the pinhole (= optical axis of the telephoto lens)
as seen from the mirror. You may use the nominal 0.5 m focal length of the mirror in
your derivation of this off-axis angle. Then turn off the laser and return the QTH light
source and condensing lens to their former positions. Alignment prior to the pinhole
is not critical given the diffuse illumination following the opal glass. You should now
be able to pick up the image of the pinhole formed by the mirror in the microscope.
Adjust for focus and best alignment.

Part B Configuration and Measurements - PC Model

To enter the spherical mirror’s parameters into Code V, reset the software with
“File → New.” Set a single wavelength of 550 nm and an entrance pupil diameter of
50 mm, using the “Lens → System Data → Wavelengths” and “Lens → System Data
→ Pupil” menus. Insert 3 surfaces:
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Surface Radius Thickness Glass RMD Aperture
STO 600 25

2 −1000 0 REFL 25
3 500 25

Now you need to specify the tilt of the mirror. Find instructions for this in the
small Code V manual and ask if you need help. Make sure the surface type is “reflect”
and you have specified it to decenter and tilt. Specify an A-tilt of however many degrees
you measured the mirror tilt to be.

Repeat this for surface 3. You can now draw the lens and perform other analyses
as you did before.

Finally, switch to the measuring eyepiece, calibrate its divisions with the Ronchi
Ruling, and determine the length and width of the image when the focus is adjusted
to minimize the image size. Make the same measurement using Code V and compare
theory to observation. Do you see color in the image when viewed through the micro-
scope? Where does this most likely come from ? If your theory can be tested, do so
before turning off the light source and record the results of your tests.

Part B Analysis. Calculate (not using Code V!) the spherical aberration you
would expect to be present were the 50 mm diameter, 0.5 m focal length spherical
mirror used on-axis, and compare to the spot sizes observed at the off-axis angle used
in this lab. What is the minimum spherical aberration blur size on-axis in units of
arcseconds?

Part A and B Discussion. Compare the range of image spot sizes encountered
in this lab to the diffraction limit for λ = 500 nm light in a 50 mm aperture lens
or mirror. By what factor would the observed spot sizes need to decrease before
these optics would become “diffraction-limited?” Would you expect that aberrations
or diffraction effects are more important in practice usually with lenses of 2-inch and
larger diameters? Why?

Without searching through textbooks or the literature or performing tedious cal-
culations, consider finally your achromatic doublet lens: this lens is designed to bring
two wavelengths of light to a common focus. The residual chromatic differences at in-
termediate wavelengths is known as “secondary chromatic aberration” (or “secondary
color” in the vernacular). Was the image produced by the achromat you observed
white (i.e. entirely colorless)? Do you think it is possible to design a system of lenses
that is corrected for secondary color—that is, one that brings three wavelengths to a
common focus? Speculate (don’t do any real work) on what this might involve.

Epilogue.

Though outside the scope of this course, you may be interested in knowing that
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one of the major uses for programs like CodeV is for optical design. The computer can
be used to optimize the radii, spacings, surface shapes, and even glass types used in an
optical system so that the aberrations present in an image are minimized.

A related topic which becomes necessary once you have designed custom optics is
“tolerancing.” If your optical system lens has been optimized using CodeV and produces
the optical quality you require, the question arises as to how the slight errors that are
inevitable in any manufacturing process in the relevant optical parameters (e.g. optical
system radii, thicknesses, spacings, etc.) will degrade the optical performance the is
predicted for the idealized image.


