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Introduction: 
 
      The NGPS GUI software described here consists of two related programs: ngps-observe and ngps-plan. 
As the names imply, ngps-observe is used to carry out observations with the NGPS instrument. The ngps-plan 
program on the other hand is used for preparing plans for observing. In fact, the code is identical and is simply 
configured for the two distinct roles at run time. The biggest difference between the two programs is that ngps-
observe connects automatically to the observation sequencer running on the ngps computer and can only be 
run on that computer for full functionality. The ngps-plan program on the other hand can be run from anywhere 
and only requires a network connection to connect to the MySQL database that stores the observing run data.  
 

Accessing the NGPS Computer 

 
Both the planning tool (ngps-plan) and the observing tool (ngps-observe) must be run on the ngps computer 
which is located at Palomar Observatory. Accessing the ngps computer requires a Caltech IP address so you 
must either be located on campus or use the Caltech VPN. 
 
     Accessing the ngps-observe program is done through a VNC client that allows remote access to the ngps 
computer while it is deployed at Palomar Observatory. When the instrument is deployed on the Caltech campus 
(expected later in 2023) the instrument will be accessed the same way.  
VNC Connection parameters:  
 
    198.202.125.142:58033    Account: XXXXXXXX    Password: XXXXXXXX 
 
There is only one VNC server so if another user is already connected then you will not both be able to use it 
simultaneously. 
 
The ngps computer can also be accessed via SSH. When using SSH any number of users may simultaneously 
access the ngps computer and run the planning software without affecting any other users. 
 
Accessing via SSH requires no password but you must supply us (an ngps administrator, or dhale@caltech.edu) 
with your public key. It is strongly advised that you generate an ssh key specifically for connecting to the ngps 
computer rather than re-using an existing ssh key. To generate a public/private key pair, from Mac, Windows or 
Linux, navigate to your computer’s command line prompt and type the following: 
 
  ssh-keygen -t ed25519 

 
You will be prompted for a file in which to save the key. You may use any filename you like here. 
After entering a filename, you will be prompted for a passphrase. This is your own personal passphrase to 
access your private key. You will never share this password with us or anyone else. The purpose of this 
passphrase is to protect your private key. It is optional, and you can press enter for no passphrase. The 
consequences of not providing a passphrase means that anyone with physical access to your computer will 
have the ability to use that private key. The consequence of providing a passphrase means that you will have 
to enter it each time you want to use your private key. 
 
You will have now generated two files with the keyname you selected above, a private key (keyname) and a 
public key (keyname.pub). The private key must be stored in 
 
     your_home_directory/.ssh/keyname 

 
and must remain private; you never share this file. 
 

mailto:dhale@caltech.edu


The public key can be stored anywhere and is safe to share; it should be emailed to dhale@caltech.edu. After 
your public key has been received and installed you will be able to access the ngps computer from off-site using 
ssh as follows: 
 
    ssh -Y observer@hale.palomar.caltech.edu -p 58031 

 
If you are prompted for a password, then it’s possible you may have multiple key pairs and ssh is not selecting 
the correct one that you have provided for ngps. In that case, specify exactly the name of the keypair as follows: 
 
    ssh -Y observer@hale.palomar.caltech.edu -p 58031 -i keyname 

 
where keyname is the full path and filename of your key. 
 
To access the ngps computer from on-site (from within the Palomar network) use the following: 
 
    ssh -Y observer@10.200.129.162 

 
Once logged in, type 
 
    ngps-plan 

 
at the terminal prompt. 
 
Testing the program should primarily be carried out in the observer account rather than developer. The preferred 
VNC client is available from RealVNC at the following link:  https://www.realvnc.com/en/ 
Install the RealVNC client for your preferred operating system (or use another VNC client such as tigervnc or 
tightvnc) and then point the client to one of the addresses listed above. This will open a desktop where you can 
start the program. 
     In the upper left corner of the desktop there is an “Activities” icon. Select this icon and the toolbar will show 
up on the left side of the screen. Select the “Terminal” icon and a terminal window will pop up on the desktop. 
You start the ngps-observe program by simply typing “ngps-observe” in the terminal window followed by a 
carriage return. Starting the ngps-plan program is the same, simply type “ngps-plan” in the terminal window. 
 

Carrying out your first observation:  The simplest example, no target list, just a 
target 

(1) Start the ngps-observe program. 
(2) Select the File > New Target List 

 
 
Figure 1 File>New Target List Menu 

(3) A single line is added to the main table. Fill out all the required parameters by directly editing the cells in 
the table.  

 
Figure 2 New Target Set ready for editing 

mailto:dhale@caltech.edu
https://www.realvnc.com/en/


(4)  Additional parameters can be modified in the Observation, ETC and Plan tables on the right side of the 
GUI. To access the additional parameters for a particular object the target must be selected and highlighted. 

(5) For example, the following entries set up an observation of M51 for 900 seconds. 

 
Figure 3 New Target List after editing 

(6) Once you are satisfied with the parameters you need to save the “target set” to the database so that it can 
be accessed by the observation sequencer. Click the “Accept” button on the right-hand side of the GUI. 
Since you have not saved this target set to the database, it will prompt you to enter a name for the target 
set: 

 
Figure 4 Providing a name for the target list 

(7) Each time the “target set” M51 is saved, the OTM (Observation Timeline Modeler) will be run on the set of 
targets and a plot will be displayed to the observer. 

 
Figure 5 Timeline model of the new target list M51 

As you can see from the plot, a single observation is scheduled at the beginning of the night (M51) for 900 
seconds. The target happens to be near zenith at the start of the night so the observation can be carried out 
right away as soon as the evening twilight begins. 
(8) The observation may be carried out by pressing GO button (this depends on the observation sequencer 

(OS) being running and ready to carry out observations). 
 

Carrying out your first observation:  Starting with a CSV file 
 

(1) Start the ngps-observe program in a terminal window 
(2) This time we will assume that you are starting with a CSV file that contains your target descriptions.  
(3) Upload your target set CSV file to the ngps computer (using scp?). 
(4) This time we want to save this CSV file in the database so we would prefer to store this in our personal 

space. We are going to create an “owner” account and then log into it.  
(5) In the upper right-hand corner of the program there is a menu that initially just says “Guest.” Click on this 

menu and bring up the create user's dialog. 



 
Figure 6 Creating a new "owner" 

(6) We will create an owner with the owner_id = “NGPS_observer” and we will supply a password in both the 
password and confirm password fields. Press the “Create OWNER” button and the new owner account will 
show up in the Account OWNERS table. You may now close the dialog by selecting the X in the upper 
right-hand corner. 

(7) Now we will log into the account using the Sign-In dialog: 

 
Figure 7 Signing into the new NGPS_observer account 

First select the Owner in the list on the left and then provide the password for this account. Click the “Sign In” 
button, if the password is correct, you will be signed in and the dialog will disappear. If you make a mistake, it 
will prompt you again.  
(8) Once you have signed into the account the menu prompt in the upper right corner changes to reflect that 

you have logged in. 

 
Figure 8 Confirmation that you have logged in 

(9) Now that you are signed in, we are ready to import the CSV file. Go to the File > Import menu and a file 
selection dialog will pop up. Browse through the file system and select the appropriate file. 

(10) The “Import CSV” dialog pops up and displays the contents of the CSV file. The first tab in the dialog 
displays how the CSV file has been interpreted. Each column in the CSV file has been mapped to a column 
in the table. Where parameters required for running the ETC and the OTM are missing from the CSV file 
the appropriate defaults are set in the import table.  



 
Figure 9 Importing the CSV file 

(11)  If you run into a problem with the format of your CSV file, you can edit the raw text in the “Text View” panel. 
Once you have modified the text in the Text View panel, you must parse the input file again to update the 
table with any changes. 

 
Figure 10 Editing the CSV file text 

(12)  Once you are satisfied that the parser is reading your file correctly, you are ready to import the target set 
into the database. When you click the “OK” button on the Import CSV dialog it will open another dialog 
asking for a target set name for this observation file. Enter a name and then click “OK.”  



      
Figure 11 Importing and saving the CSV file 

(13)  The CSV file has now been imported into the active database and all future manipulation is done using 
custom tools built into the ngps-observe and ngps-plan GUI’s. 

(14)  The main table should now be populated with the data from the CSV file. Additional parameters needed to 
automatically run the ETC and the OTM are included in the tables and can be used to fine tune the 
scheduling and the estimated parameters (e.g., SNR). The OTM is automatically run each time the “Accept” 
or “Save” function is carried out. The standard way to work with the system at this point is to modify the 
order (observation order) of the observations, the date of the observations and the amount of time dedicated 
to each exposure.  

 
Figure 12 Imported CSV file and timeline display after saving to the database 

 
 
 



The Planning and Observing GUI’s 
 
       The following sections describe the graphical user interfaces to the underlying software modules. There 
will be two main windows: Planning and Observing. These windows look identical, and it is suggested that they 
might be located on physically different displays to not confuse their roles, but they will be identified with their 
title bars as "Planning" and "Observing". The main feature that sets apart the Observing window from the 
Planning window will be the Observation Sequencer controls and indicators, which are present only in the 
Observing window.  
The Observing Window will always appear at the same display location, not resizable, and will not overlap with 
any other windows.  
The two windows will follow the same style as familiar windowed environment tools, having a menu bar format 
across the top, "File, Edit, View, Tools, etc."   
Using common notation, menu options that are followed by ellipses "..." indicate that additional information will 
be required before the action is taken. Menu options without ellipses indicate that action will be taken 
immediately upon selection.   
The Observing Window is the main user interface to the instrument.  
The Planning Window is an optional component.  

Observing Window  
This is the main control point for the instrument. The Observing window frame will have a window titled 
"Observing" and a grey-colored outline. These two indicators, along with window location on the display 
terminal, distinctly identify the observing window from the planning window. See Figure 12.  
Only one Observing window can run at a time; the software will prevent multiple simultaneous instances of the 
observing window.  

 

(1) Standardized Menu Bar  
Across the top of the observing window, left-justified, is a menu bar with the following drop-down menus:  

• NGPS  

• File  

• Edit  

• View  

• Tools  

• Help 
 
And right justified in the menu bar: Sign In... or Username  

 

At the right side of the window menu bar is the name of the currently logged-in user when a user is logged-in, 
or the phrase "Sign In..." if no user is selected. This is a clickable button. The user can click "Sign In" to sign in 
or if already signed in then they can click their username which brings up a pulldown menu with the option to 
set account details or to sign out.  

 

Target Table  
It reduces missed opportunities. This list represents the target set which will be observed by the sequencer. 
The table is always present, in a fixed size and location within the window. When the software is first started, 
this table is presented with empty columns, but the column names are present. A vertical scroll bar at the right 
will allow scrolling through a lengthy list.  
There is no horizontal scroll bar because there is always a fixed set of columns displayed, as follows: Target, 
RA, DEC, Req Exptime, Exptime, SNR, Req Slit, Slit, and Airmass, and Note. Additional fields are contained in 
a detail pane to the right of the table which is described later (§5.1.3).  
The software opens an empty table of an undefined name. Users may open previously saved tables, insert 
target lists from a CSV file, or simply type directly into this table (using Edit > Insert Target or by right-clicking 



within the table, as discussed in the Edit Menu section, §5.1.15 and the Right-Click Edit Menu section, §5.1.16, 
respectively).   
After a target list is loaded (either by File > Open or by File > Import), the name of the target list is displayed 
at the top of the target list table. This is the name of the target list in the database. Since any target(s) displayed 
in this table can be used for observation, and the Sequencer reads its targets from the database, every target 
list must therefore be saved in the database. The user will be prompted, as necessary.  
Manipulation of targets in the list is done using the pull-down menus, keyboard shortcuts, or by right-clicking on 
a target, which pops up a menu of copy, cut, paste, insert, etc. options which work identically to Excel and many 
other Microsoft and Apple applications. Targets can also be moved in the list by simply dragging and dropping 
them into place. Multiple rows can be selected (for copy/cut/drag) by holding down the SHIFT key while 
selecting the rows.  
Most of the fields are editable directly in the table or detail pane; those which cannot be edited are displayed in 
grey text (for example, OTM output fields are not editable). If the user edits an OTM input field, then the following 
actions occur:  
1. All OTM output fields from the edited target through the end of the list are erased.  
2. Some columns will be transferred:  

a. "SET x" in the Req Exptime field will be transferred to the Exptime field.  
b. "SNR x" in the Req Exptime field will be transferred to the SNR field.  
c. "SET x" in the Req Slit field will be transferred to the Slit field.  

3. The pair of "save changes" icons (normally greyed out) are illuminated.  
Changing any value in the target list table while the sequencer is running will automatically switch the Sequencer 
Option to Single Step (§5.1.8). This prevents the sequencer from reaching rows that the user has changed but 
has not saved to the database.  

 

Detail Pane  
A detail pane is always present to the right of the main table, also with a fixed size and location, but is not 
always filled with information. The detail pane is only filled when a target is selected in the target list. When a 
target is selected in the main table, the detail pane shows all the information for that selected target, organized 
by three tabs:  

1. Observation. Contains observation and instrument required columns, which are 
those shown with checkboxes in the "OS" column in Table 1.  

2. ETC. Contains ETC input columns (no overlap with previous tabs), which are those 

shown with checkboxes in the "OTM+ETC" columns in Table 1  

3. OTM Plan. Contains OTM output columns, which are those shown in Table 2 

 
The tabs are colored in muted but distinct colors as indicated above. Columns in the main table are colored 
according to the tab category under which that column falls.  
The top of the detail pane always displays the target name, outside the tabbed area. This allows a user to view 
all information associated with the selected target without losing sight of the target name.  
Units for applicable columns are displayed in the Detail Pane.  



  

Figure 13 Observing Window when the GUI is started 

Save Changes Icons  
In the upper right panel with the planning tools Immediately above the table is an area for a pair of icons 
represented by a green check mark and a red cross, or "X". These are here because the user can edit any input 
field directly in the table. Targets can be dragged and dropped, cut/copied/pasted, and the user can click in any 
input field and type a new value.   

 
Figure 14 Save Changes Icons 

These icons are normally greyed-out but when any change is made to the target list table then they become 
highlighted and/or brightly colored – this is the user's signal that their table is not saved, and any OTM-calculated 
fields may be stale.  
At this point, the user has the option to abandon their changes and reload the last saved table from the database 
by clicking the red "X" icon. Clicking the green check icon will perform the following functions:  
1. Run the OTM if needed (the GUI automatically identifies when an "OTM-sensitive" field was edited and sets 

a flag which indicates that the OTM needs to be run).  
2. Repopulate the table with OTM outputs (if the OTM was run).  
3. Save the final table in the database.  
Menu options File > Save and File > Save as... perform the same functions (except in the case of Save as..., 
the save-as dialog window is presented, as described elsewhere).  

      Timeline Modeler Controls  

 
The upper right area of the Observing Window (Figure 15) displays OTM controls. This area contains text boxes 
for important user-inputs required by the OTM: start time, seeing, and sky background. When the GUI is started, 
these fields are initially auto populated with default values read from a configuration file. These controls are 
placed on the front panel because their values are critical to the calculated values in the table.  
Adjacent to both the start time field, and the pair {seeing & background} fields is a checkbox labeled "AUTO". 
When AUTO is unselected, the text fields are manually set (you can type in them). Any previous value is not 
erased when unselecting AUTO; selecting AUTO retains any automatically retrieved value.  
The AUTO selection works as described in the following subsections.  



 

AUTO Start Time  
When AUTO start time is selected, the start time field is greyed-out and filled according to the following rules:  
1. The user can select AUTO on their own, in which case,  

a. if the Sequencer is running, then the start time is taken from the actual start time of the last exposure 
that was started.  

b. If the Sequencer is not running, then the start time becomes a live clock, displaying current time (and 
hence is "ticking" with each passing second).  

2. When "DO ALL" is selected (§5.1.8) and the Sequencer is running, the GUI automatically checks the start 
time AUTO checkbox.  

 
      AUTO Seeing/Background  

When AUTO seeing/background is selected (one button is associated with both fields), the seeing and 
background fields are greyed out and are populated by retrieving these values from the ACAM Daemon.  

 

      Twilight  
The start time field has an adjacent button labeled Twilight. This button is active only when AUTO is unselected 
and is greyed-out when AUTO is selected. Clicking this button will fill the start time field with the predicted 
twilight for the current day; the field remains editable.  

 

       Fetch Live  
The seeing/background fields have an adjacent button labeled Fetch Live. This button is active only when 
AUTO is unselected and is greyed-out when AUTO is selected. Clicking this button will fill the seeing and 
background fields with values retrieved from the ACAM Daemon, automatically run the OTM (updating the OTM 
output fields in the table), and the database table will be saved. If the sequencer is running, then the Sequencer 
Option will be switched to Single Step. The fields remain editable.  

 

      System Status Indicator  
A colored box at upper left displays the current system status. This status will be one of those shown in the 
leftmost column of Table 7 ("Indicator"). In general, black and grey indicate dead time; amber and yellow 
indicate that the system needs attention.  

 

      Status vs. State  
The first column in Table 7 indicates status which is different from the states in Figure 5. The GUI will have to 
infer the following status indicators:  

Status  State 
or Flag  

Infer from State and...  

No 
Targets  

READY  empty target list table  

Idle  READY  target list table loaded  

  
       System Control  

One or more colored and labeled pushbuttons are displayed at lower left under an area labeled "Available 
Actions". Only the button(s) for the currently allowable action(s) are displayed (e.g., when "stop" is not an option, 
given the current state of the instrument, then the stop button is not displayed). The possible control buttons 
displayed for each state are shown with their accompanying states in Table 7.  
When the software is first started it is in the OFFLINE state, at which point the only possible action "startup" so 
only one button is displayed.  
After starting up, the system is ready to observe so the status reads Idle if there are any targets listed or No 
Targets if there are no targets in the table. Clicking Go will immediately start observing, either a single target at 
a time or the complete list, depending on the state of the "Single Step / DO ALL" radio button located 
immediately above (see §5.1.8).  
Clicking Go will start the observing which will proceed through various states as indicated in the first column of 
Table 7.   



The indicators Stopping and Aborting are used when a stop or abort is selected, since these may take some 
time to complete.  
 
Stop...  
When the user selects Stop..., a floating dialog window appears, not attached to anything. The dialog will contain 
the text, "Stop: Are you sure?" along with three buttons, as follows:  
       1. "No"  
2. "Yes, stop and idle"  

      3. "Yes, stop and go to next target"  
Clicking "No" will close the dialog and no further action occurs.  
Clicking "Yes stop and idle" will set the sequencer option to "Single Step" (by sending the "do one" command 

to the sequencer) and then send the "stop" command to the sequencer.  

Clicking the "Yes stop and go to next target" will set the sequencer option to "Do All" (by sending the "do all" 

command to the sequencer) and then send the "next" command to the sequencer.  
        
      Abort...  

When the user selects Abort..., a floating dialog window appears, not attached to anything. The dialog will 
contain the text, "Abort: Are you sure?" along with two buttons, as follows:  

1. "No"  
2. "Yes, abort and idle"  

Clicking "No" will close the dialog and no further action occurs.  
Clicking "Yes abort and idle" will set the sequencer option to "Single Step" (by sending the "do one" command 

to the sequencer) and then send the "abort" command to the sequencer.  

  



 

Figure 15 Table System Status Indicators and Control Buttons 

System Status Indicator  
Action Control Button(s) 

Displayed  
Remarks  

  
  

The system is offline (power off, dust 
covers closed, etc.) and needs to be 
started.  

  
  

The system is ready to observe but the 
"Go" button is greyed-out because no 
targets have been loaded.  

  
  

Target list is loaded, and the sequencer 
is ready to be started; the system is idle, 
waiting for the user to click "Go".  

  
  

The sequencer was started but is 
waiting for the TCS Operator to initiate 
the slew.  

  
  

The TCS slew has been initiated. The 
user can abort now; this may or may not 
abort the slew, but it will abort the 
pending observation.  

    

The ACAM is acquiring the target. The 
user can abort now; this will abort the 
acquisition sequence and the pending 
observation.  

    

The sequencer is waiting for the 
airmass of the current target to cross 
the limit set in the GUI before starting 
the exposure. The user can change the 
airmass limit or abort the observation.  

  

  

The shutter is open, and exposure is 
underway. The user can pause, stop, or 
abort the exposure.  

  

  

An exposure is paused. The user can 
resume, stop, or abort the exposure.  

  
n/a  

The sequencer is in the process of 
stopping; there are no actions to take.  

  
n/a  

The sequencer is in the process of 
aborting; there are no actions to take.  

  
n/a  

The instrument is starting up, powering 
on equipment, establishing 
communication with subsystems, 
homing motors, if necessary, etc.  

shutting...      

  



      Sequencer Options  
 

 
Figure 16 Do One / Do All Sequencer Options 

There are two Sequencer Options available on the front panel, at upper left in an area labeled "Sequencer 
Options." One is the airmass limit, which forbids the sequencer from starting an exposure until the active target 
has airmass below this value. This text entry field is auto populated with a default value read from a configuration 
file at startup but can be modified at any time by the user. (The default value will be re-read each time the 
program is started.) While the Sequencer is running, it will poll the TCS for the current target's airmass with a 
period of 60 seconds.  
The other is a pair of XOR-ed radio buttons (only one or the other can be selected; selecting one automatically 
deselects the other). When "Do One" is selected, clicking "GO" will observe the first pending target in the list 
and then return to an "idle" state; no further observations will occur. The state indicator/selector button will 
return to "GO" after the observation has completed, requiring the user to manually click "GO" again to observe 
the next pending target in the list, and so on.  
When "DO ALL" is selected then clicking "GO" will observe each target in the list in succession, until all targets 
are observed or interrupted by the user.  
The Single Step / DO ALL button can be selected at any time; if the user clicks "GO" while in the do all mode, 
selecting Single Step during an exposure will mean the system returns to idle after that exposure, requiring a 
manual start of any subsequent exposure. Similarly, the user can enable do all after starting a single step 
exposure to continue the list processing.  

       Active Target Indicator  
At the top of the target list is a green-colored frame (or another similar indicator TBD) which outlines (or 
otherwise points to) the current active target; therefore, this indicator is only present while the sequencer is 
running. This indicator remains fixed to the active target which affixes it to the top of the list because it is always 
the first target in the list being observed. As target observations are completed, the list effectively scrolls up 
"behind" this indicator, with the completed targets scrolling out of this frame and out of view. If one wanted to 
see the completed targets then one can scroll the list down, in which case the completed targets would be 
displayed in grey text and the active target indicator frame would consequently move down, to remain around 
the current target being observed.  
The user may scroll the list, but the user has no control over the placement of the active target indicator; in 
other words, the active target indicator is "affixed" to the active target, not the table display. This is illustrated in 
Figure 16 where the upper panel shows the active target indicator at the top row; in the lower panel the user 
has scrolled down, revealing three completed targets. The active target indicator remains on the same target 
on both panels. Note also that the user has clicked on a different row (highlighted in yellow) which is also 
reflected in the detail pane at right.  
Clicking the "home" button at the upper right of the target display will bring the active target indicator to the top 
row again.  



 

 
Figure 17 Active Target Indicator  

The purpose of displaying targets which have been observed is not only to allow the observer to see what they 
have done, but to allow any of these targets to be copied and inserted/pasted so that observations may be 
repeated (after editing setup parameters.  Parameters for targets already observed cannot be edited until a 
copy is inserted below the current target.    

        

 Progress indicator  
At the top of the display is a pair of progress bars which indicate the total and elapsed times of the current target 
observation; this means the progress bars indicate exposure time, readout time, telescope slew, and any other 
overheads.  
The left bar indicates the progress of overhead operations including slew, settling, acquisition, etc. The right 
bar indicates the progress of the exposure. In both cases, the elapsed time of the task (underway or pending) 
is displayed within the bar along with the total duration. Figure 18 shows two progress indicators that illustrate 
this. In the upper panel of this figure the sequencer is seen to be waiting for the focus, Cass rotator, and the 
TCS but since the TCS is the dominant delay, the slowest axis, "DEC" in this case is shown in the progress bar 
(currently at 29 out of 35 s). The exposure progress indicator shows that the exposure delay of 905 seconds is 
coming up next. In the bottom panel the telescope slew has completed, and exposure is underway, now at 680s 
of 905s exposure time.  



  

 

Figure 18 Progress Indicator in the Observing Window   

Message Display  
A message display box lies above the target list window. This box displays carefully formatted messages (i.e., 
not a "dump" of log messages) which describe the status of the system, including what the system is waiting 
on. For example, "exposing", "reading out", or "waiting on slew", as well as any critical errors, calibration lamps, 
filters, etc.  
When the wait is for a human (e.g., TCS Operator) then there should be an additional indicator, such as a 
blinking indicator and/or beeping, to call attention to the fact that the system is waiting for human input.  

NGPS menu  

 
The NGPS pulldown menu contains the following items:  

• About. Contains version info, compilation date, etc.  

• Preferences... Opens a dialog window to set items listed in sub-heading below. The system defaults are 
stored in a .ini file which is read when the software is started. Changes made in this dialog apply only to the 
current session;  

• Shutdown.  Performs the shutdown procedure, which closes all dust covers and powers off all subsystems. 
This is considered an end-of-night procedure. The software continues to run, changing the state 
indicator/selector button to read STOPPED.  

• Quit. Always prompt "Are you sure?". If not currently in the OFFLINE state, then notify the user that they 
must shutdown first.   

•  
      Preferences...  

The "NGPS > Preferences..." selection opens a dialog window with the following options:  

• start time for calibrations  

• sun altitude for observing start (relative to horizon, positive for sunup)  

• sun altitude for observing end  

  



 
      Sign in... menu  

 

 
Figure 19 The Sign-In Menu 

When signed out, the "Sign in..." menu is displayed and when clicked, the user is presented with a dialog 
window to sign in with a username and password, or a one-click button to sign in as Guest (in which case no 
password is required).   
When signed in, the "Sign in" menu displays the username. Clicking the username opens a pulldown menu with 
the following options:  

• My Account...  

• Switch Users...  

• Sign out  
In Figure 15 the user has not signed in yet, but in FIGUREXXX (and inset above) the user is signed in as Guest.  

       
      My Account...  

The "My Account..." selection from the User/Sign-in pulldown opens a dialog window with the following options:  
             change password  
             add proposal ID  

        
       File menu  

The File menu pertains to the manipulation of target lists.  

 
Figure 20 The File Menu 

 

New List. Empty the list upon confirmation ("Are you sure?"). The active target list will be emptied. Greyed-

out if the sequencer is currently running.  

Open... Open a file selection type of dialog to open an existing target list from the database; this will become 

the active target list. Greyed-out if the sequencer is currently running. See description below, under subheading 
"File > Open...".   

Load from Planner. This will copy the contents of the target list from the Planning window into the observing 

window, for the logged-in user only.  

Save. Save the current target list to the database using the current name. If no name has been saved yet, then 

prompt the user for a name. Prior to saving, the OTM will be invoked if the GUI detects that an OTM input field 
was edited.  

Save as... Open a file selection-type of dialog to save the current target list to the database under a new name, 

to be selected by the user here. See detailed description below, under subheading "File > Save As...". Prior to 
saving, the OTM will be invoked if the GUI detects that an OTM input field was edited.  

Import See description below, under subheading "File > Import...".  



Export Opens file selection dialog window to select an existing .CSV file or input a new name to write the 

target list to, as a .CSV file.  If the user tries to export to an existing file, then pops up a new floating dialog that 
reads, "<filename> already exists. Do you want to replace it?" There will be two buttons labeled Cancel and 
Replace. Clicking Cancel will abort the export operation and clicking Replace will replace the existing file. After 
either button is pressed, this popup window closes.  

 

File > Open...  
The File > Open... menu pops up a selection dialog in a separate window which is floating on top of the main 
display window and is not attached to anything, as shown in Figure 18. This dialog is titled "Open target list 
table" and contains a list of the saved target lists in the database. It displays an ID number (internal reference 
only), the name, the number of targets in the list, and the times of creation and last modification.  

 

 
 

Figure 21 File>Open .... Selection Dialog  

Cancel will close the selection dialog window and return the user to the main display shown in Figure 15. 
Clicking Open will load the selected target list, close the selection dialog window, and return the user to the 
main display, filling the displayed table with the contents that were just loaded and displaying what is shown in 
Figure 22.  

       

File > Save As...  
The File > Save As... selection pops up a selection dialog in a separate window which is floating on top of the 
main display window and is not attached to anything, as shown in Figure 19. This dialog is titled "Save target 
list table" and is similar to the File > Open dialog except in addition to having a list of the saved target lists in 
the database it also contains a text box which allows entering a new name. This text box will be filled with a 
default name of "TargetList1" which can be edited. If TargetList1 already exists then TargetList2 will 

be the default, etc., increasing the number as needed. The dialog has a Cancel and a Save button. Clicking 
Cancel will close the selection dialog window and return the user to the main display without saving the target 
table. Clicking Save will save the target list with the name in the text box.   

 



 

Figure 22 File > Save As ... Dialog         

File > Import...  
The File > Import... pops up a standard file selection dialog in a separate window which is floating on top of the 
main display window and is not attached to anything, as shown in Figure 20. This file selection dialog is looking 
for files with the .CSV extension (so that non-CSV files are greyed out). Within this file selection dialog are two 
buttons labeled Cancel and Get Data. Pressing Cancel will close the file selection dialog and return the user 
to the main window as shown in Figure 15.   

 

 
Figure 23 File > Import ... Dialog  

Clicking Get Data will cause the file selection dialog to close and a new popup window to appear, floating on 
top of the main observing display. This popup window (shown as blue in Figure 21) shows a table presentation 
of the raw CSV file which was just selected.  
The CSV-table popup in Figure 21 has the title, "Import CSV: filename" and allows the user to check their CSV 
file for errors; it also allows editing. The table being edited here exists only in memory and is not committed to 
the database until the user clicks Import (more on this later). The name of the .CSV file is displayed at the top, 
along with the current action (i.e., "Import CSV: filename") and at the bottom a default database table name is 
pre-filled in the text box using the CSV filename without the CSV extension. The name can be edited. "Cancel" 
and "Import" buttons are displayed at the bottom of this window.  
Also across the top of the import dialog are tabs which allow displaying the CSV in table format or the original, 
raw CSV format.  



  
 

 
 

  
Figure 24 CSV Import Dialog 

Clicking Cancel in this popup will close the popup and abort the import.  

 

Clicking Import in this popup will perform the following sequence of operations:  
1. The table name will be checked against existing ones, and if the name exists, the user will be prompted to 
confirm overwriting the existing table. Overwriting the existing table will completely replace it with the contents 
read from the CSV file. Note that a user cannot overwrite an existing table if that table is currently being run by 
the sequencer.  
2. Perform the NEXP expansion. For NEXP > 1, each row in the target list will be replaced with An identical 
rows.  
3. The main target table (the one shown empty in Figure 15) will be filled with values that were read from the 
CSV file. There will still be some columns that have yet to be filled out by the OTM/ETC.  
4. The OTM/ETC will be run automatically using the OTM parameters displayed at the lower left of the front 
main window.   
5. The popup dialog in Figure 21 closes and the user is presented with the main window again, but now the 
target table is filled in, as shown in Figure 22.  



  
Figure 22. Observing Window Loaded Table  

After importing the CSV file, the user is presented with Figure 22; the targets have been saved into the database 
using the name specified above, and they are displayed in tabular form in the main window. The Detail Pane is 
by default filled with the active target information.  
Columns are color-coded according to which of the four tabs they belong (§5.1.3 Detail Pane).  
In case of an OTM/ETC failure, an error message is displayed in the messages window. This is a "formatted" 
error message (in other words, it is not a "raw dump" of the OTM output). The OTM raw output can be optionally 
viewed by selecting "View > OTM output" from the menu bar (see View menu, §5.1.17).  
In case of an OTM/ETC flag, the entire row for the flagged target will be colored amber (like the GO button). 
The amber-colored row supersedes any column colors (i.e., the entire row is amber and there are no uniquely 
colored columns by tab).  

       

 Edit menu  

 
Figure 25 Edit Menu 

Insert New Target.  Insert new target into table above cursor filling in default values.  Users can          then 

edit these values. If the target set name is undefined then popup the "Save As..." dialog window (Figure 19) to 
prompt the user to enter a target set name.  

Get Target from database... Opens a dialog window to enter search parameters to retrieve a target from 

the database. Search on any field(s). Inserts target above current cursor location. See subheading below for 
details.  

Cut. Remove the selected target row from the list, after storing a copy in copy paste buffer.  Greyed-out if no 

selection.  

Copy. Copy the selected target row from the list into copy-paste buffer.  Greyed-out if no selection. Completed 

targets may be copied. If a completed target is pasted or inserted, the STATE column will be automatically set 
to PENDING.  



Paste. Paste the copied target row into the list at the current location, overwriting the current row. Greyed-out 

if nothing was cut or copied or if no row is currently selected. When the sequencer is running, target rows can 
only be pasted below the active target.  
Insert Copied Cells.  Inserts contents of copy-paste buffer above the current location, or at the top if nothing 
is selected. Greyed-out if nothing was cut or copied or if no row is currently selected. When the sequencer is 
running, target rows can only be inserted below the active target.  

 

Getting a Target from Database...  
The "Edit > Get Target From Database..." option allows a user to retrieve a previously observed target by name 
(along with its associated settings) from the database. Selecting this option displays a popup dialog window as 
shown in Figure 23, titled "Get Target from Database" and in which there is a text entry box for the target name 
to search for, and Cancel and Search buttons. This is a case-sensitive search. Clicking Cancel will close the 
dialog window. Clicking Search will search all the target lists the current user can access.  

  
Figure 26 Edit > Get Target From Database 

If no match is found then the text, "no match found" is displayed within the dialog window; the dialog box 
remains, and the user may choose new search criterion or click Cancel.  
Otherwise, the target name may match one or more targets across all the tables the logged-in user can access. 
If one or more matches are found then the search dialog window closes and a new floating dialog window 
opens, titled "Search Results: target name" as shown in Figure 24. The user selects which of the rows they 
want and clicks Insert. This has the effective action of copying that target row and inserting it into the current 
targets table above the currently selected row.  

 
Figure 27 Get Target From Database Search Results  



 

Right-Click Edit Menu  

 
Figure 28 Right-Click Edit Menu 

Right-clicking on a target row directly in the table will display a similar edit menu at the mouse pointer location, 
with the options of Cut, Copy, Paste, Insert New Target, Insert Copied Cells and Move to Top (NB. this is 
intended to mimic the experience in Microsoft Excel). Completed targets can be copied and pasted into the 
pending targets, but (in the Observation Window) the user cannot paste into the completed targets. Copying a 
completed target into the area of pending targets will automatically set the target state to "PENDING".  
If Insert New Target is selected and the target set name is undefined then popup the "Save As..." dialog window 
(Figure 19) to prompt the user to enter a target set name.  
Move to Top will move the selected target to the top of the list of pending targets, making it the next in line to 
observe.  

 

 View menu  
OTM Output.  Opens a floating popup window to display the raw OTM output. This popup features a text 
window and a "Close" button which closes the popup window.   

 
Figure 29 View Menu 

Zoom in. Increase font size for target list and details only. I.e., fonts on menus and buttons are 
unaffected.  Greyed-out when zoom at max-allowed.   

Zoom out. Decrease font size for target list. Greyed-out when zoom at max-allowed.  
Plot... Opens a dialog window for plot controls, including what to plot, formatting options, etc. and includes a 
plot button (no ellipses) within that dialog window to display the plot. Plots will appear always in the same 
window, i.e., plots are displayed in their own floating window, but repeated clicks will continue to display each 
new plot in the same plot display window.  

 
Tools menu  

 
Figure 30 Tools Menu 



Sort Target List by RA. Re-orders the displayed target list by increasing RA value; applies only to PENDING 
targets (this cannot be undone).  
Optimize observation order...  Opens a dialog window to provide various optimization options. This is 
currently greyed-out, reserved for a future feature.  

Hourly weather forecast.   
10-day weather forecast.   
Ephemeris.   

Line list.   
Report bug... Opens a dialog window which auto-fills the username, date, time, and "About NGPS" information. 
Provides text entry box for the user to type a description of the problem. The "submit" button sends an email to 
the s/w team.  
Export Observing Log... Opens a dialog window which allows the user to select the current night or enter a 
date and time range to export the observing log for the chosen period. Exported file is formatted as CSV and 
includes header row (does not include OTM outputs).  

Help menu  
Help menu selections will display either a PDF or HTML file in the appropriate system viewer.  
Quick start guide  

 
Figure 31 Help Menu 

FAQ  
• Tutorial  

• Exposure Time Calculator  

• Optimizing observation order  

• Data reduction  

• Calibration  

• Example spectra  

• NGPS instrument manual   

• Errors and diagnostics  
  

Planning Window  
The Planning window frame will have a window titled "Planning" and a blue-colored outline. These two 
indicators, along with window location on the display terminal, distinctly identify the planning window and 
separate it from the observing window. See Figure 25 for the Planning window (and compare also to the 
Observing window in Figure 15).  
The Planning window can easily be identified as not being an Observing window since the Progress Bar and 
Indicator/Selector button are absent, as well as the green Active Target Indicator frame and home button.  It is 
otherwise identical to the Observing window.   
The planning window is an optional component; it is not required for observing. The planning window provides 
a means for someone to try different observing scenarios without affecting the observing that may be taking 
place. Any number of instances of planning windows may run simultaneously.  



The planning window is stand-alone (distinct from the observing window) so a separate sign-in is required in 
the planning window.  
The target list shown in the planning window is (initially) stored only in memory, just as if one were to open a 
word processor and begin typing — the information initially typed is not automatically saved anywhere, it exists 
only in memory, until that file is explicitly saved someplace, either to the database or exported to a CSV file.  
The target list(s) created and/or saved from the planning window to the database are never the active targets 
table, but the format is identical.  Only the observing window has access to the active targets table.  

  
Figure 25. Planning Window  

  
Timeline Modeler  

For the Planning Window, the AUTO checkbox is eliminated for the start time, and replaced with a button labeled 
"current" which fills the start time field with the current time.  

File menu  
Identical to Observing > File menu (§5.1.14) except that Load from Planner is replaced by:  
Load from Observer. This will copy the contents of the active target list from the Observing window into the 
observing window, for the logged-in user only. If the Observing Window user is different from the Planning View 
user, then display an error. Prompt to overwrite the current planning view screen buffer.  

Edit menu   
Identical to Observing > Edit menu (§5.1.15).  

View menu  
Identical to Observing > View menu (§5.1.17).  

Tools menu   
Identical to Observing > Tools menu (§5.1.18).  

Help menu  
Identical to Observing > Help menu (§5.1.19).  

  


